メインコンテンツにスキップ

フィルタリング設定について

今週アップデートされました

学校・自治体などのネットワーク環境からスクールタクトを利用する際、正常な動作を確保するために以下のドメインの通信許可(フィルタリング除外)設定をお願いいたします。


1. 通信許可が必要なドメイン

許可すべきドメイン

*.schooltakt.com

*.classinote.com ※1

*.gstatic.com

*.embedly.com

*.googleapis.com

*.intercom.com

*.intercomcdn.com

*.intercom.io

*.intercom-messenger.com

*.sentry-cdn.com

*.google-analytics.com

*.googletagmanager.com

※1 ClassiNOTEご利用の場合のみ設定してください。

※2 チームタクトご利用の場合のみ設定してください。


2. 「サーバーとの接続が切れました」と表示される場合

課題のキャンバスを開いている際、「サーバーとの接続が切れました。再接続します。」 というメッセージが頻繁に表示される場合は、主に WebSocket(wss) 通信が遮断されている可能性があります。

原因

スクールタクトではおもにキャンバス画面について、WebSocket 通信を利用しています。この通信がネットワーク機器やフィルタリングソフトによって遮断されると、再接続が繰り返され、書き込みが正しく反映されないなどの事象が発生します。

対策

  • プロトコルの確認: 上記「1. 通信許可が必要なドメイン」のうち※1~※3のドメインに対して、http, https, websocket, wss の通信を許可するように設定してください。
    ※スキーマ一致の設定が必要な場合は、wss://*.schooltakt.com などと個別に追加してください。

  • 接続テストの実施: 設定を許可しても解消しない場合は、WebSocketテストを実施し、通信環境に問題がないか確認してください。

こちらの回答で解決しましたか?